¿Te atreves a demostrar lo que sabes resolviendo alguno de estos
temas abiertos/no resueltos?

Distribuir Cuotas a...
 
Compartir:
Avisos
Vaciar todo

[Resuelto] Distribuir Cuotas a través de una Macro

ramonvar
(@ramonvar)
Nuevo miembro Registered

Buen día Señores del Foro
Tengo un desafió para mi, con una ayuda de parte de Uds, Estoy seguro será mas fácil
Debo de llevar el control de Cuotas de Socios, la situación es la siguiente.:

1- Los socios, algunos pagan al contado, otros a mitad de año,
otros entregan una parte etc.
2- La idea es que una vez que se abone sea la fecha ,que fuere,
ese monto sea distribuido en los meses no pagados.

Eje. si al inicio del año entregó 720.000 que sería al contado,
sea distribuida desde ENE a DIC.
Si, a mediado del año allá por JUL, entregó los 720.000,
sea distribuida desde ENE a DIC.
Si entregó 180.000 allá por MAY, entonces será distribuida
desde ENE a MAR..
Si esta misma que entregó los 180.000, allá por DIC,
entrega lo restante, sea distribuida desde MAY a DIC.

Adjunto Planilla, desde ya mis agradecimiento.

 

Citar
Topic starter Respondido : 06/09/2021 4:46 pm
Etiquetas del debate
MacroMaster
(@macromaster)
Miembro eminente Registered

No siempre es necesario hacer todo con macros. La mayoría de las veces, las cosas tienen soluciones mas fáciles.

Lo primero, habría que analizar muy bien que es lo que quieres hacer. Como piensas reflejar en tu tabla el último caso:

Si entregó 180.000 allá por MAY, entonces será distribuida
desde ENE a MAR..
Si esta misma que entregó los 180.000, allá por DIC,
entrega lo restante, sea distribuida desde MAY a DIC.

Si vas a añadir una nueva lineo, por favor, indica con un ejemplo que resultado quieres visualizar. Si lo vas a totalizar en la misma lineo, como vas a reflejar las diferentes fechas de pago?

Por que no vas haciendo simplemente condicionales? Si el pago realizado menos la suma de importes asignados a cada mes es positivo, si es mas de 60.000, poner 60.000 y si no, poner lo que quede. Si el pago realizado menos la suma de importes asignados a cada mes es negativo, el pago de ese mes es 0. Sin macros ni complicaciones raras.

 

Saludos

ResponderCitar
Respondido : 06/09/2021 7:37 pm
ramonvar
(@ramonvar)
Nuevo miembro Registered

@macromaster 

Buenas tarde

desde ya agradecer tu tiempo por responderme, agradezco tu sugerencia, lo intentaré hacer con condicionales como me sugieres, y fue una equivocación mía la que me señalas.

Si entregó 180.000 allá por MAY, entonces será distribuida
desde ENE a MAR..
Si esta misma que entregó los 180.000, allá por DIC,
entrega lo restante, sea distribuida desde MAY a DIC.

En realidad debería ser los primeros 180.000 distribuidas entre ENE a MAR, y los otros 180.000 ABR a JUN.

Saludos

ResponderCitar
Topic starter Respondido : 06/09/2021 8:42 pm
MacroMaster
(@macromaster)
Miembro eminente Registered

@ramonvar,

no respondes a la pregunta. No me refería a ese error, sino a que si alguien hace dos pagos, vas a acumular el importe en una misma fila o vas a añadir dos filas? Si acumulas el importe, es mas sencillo, pero entonces la columna de fecha de pago no tiene sentido, porque tendrías dos fechas distintas para una sola celda.

ResponderCitar
Respondido : 07/09/2021 7:59 am
Ramón
 Ramón
(@Ramón)
Invitado

@macromaster 

Buen día, con la disculpa del caso, bueno, si, en realidad un socio puede hacer en un solo pago, dos a tres pagos en diferentes fechas, lo de la fecha es nada mas para tener el registro de su último pago, pero los monto abonados, se debería de distribuir en 60.000 por mes, ahora bien, un Ej. si un socio entregó 180.000 se distribuiría en tres meses de ENE a MAR. suponiendo que este mismo socio entregó más adelante un suma de 190.000, este monto se debería de distribuir entre los mese de ABR a JUN, y un resto de 10.000 en JUL. luego si entrega nuevamente 350.000 ahi si se le agregaría a los 10.000 de JUL los 50.000 y el resto se distribuirá has el mes de DIC

Agradecido por tu tiempo y sigo para cualquier consulta 

ResponderCitar
Respondido : 07/09/2021 5:59 pm
RET
 RET
(@ret)
Miembro Admin

Si es como dices, que en la celda de importe pagado se va a acumular el total, pero va a existir una sola fila por persona, puedes hacerlo fácilmente con la propuesta inicial. Te dejo las fórmulas para la fila 9, el resto es copiar hacia abajo:

Celda G9: =SI($F9>=60000;60000;$F9)

Celda H9: =SI($F9-SUMA($G9:G9)>=0; SI($F9-SUMA($G9:G9)>=60000; 60000;$F9-SUMA($G9:G9))  ;0)

Copia H9 a I9:R9

Copia G9:R9 a las siguientes filas

 

Saludos,

IMF_RET

https://InformaticaMuyFacil.com

ResponderCitar
Respondido : 08/09/2021 7:28 am
Ramón
 Ramón
(@Ramón)
Invitado

@ret 

Buen día. muchas gracias ret por tu tiempo y paciencia, resuelto el tema.

Podemos dar por cerrado este tema

ResponderCitar
Respondido : 08/09/2021 5:32 pm

Dejar una respuesta

Nombre del autor

Correo electrónico del autor

Título *

 
Vista previa 0 revisiones Guardado