¿Te atreves a demostrar lo que sabes resolviendo alguno de estos
temas abiertos/no resueltos?

Cálculos en TextBox...
 
Compartir:
Avisos
Vaciar todo

Cálculos en TextBox y Label.

jopi
 jopi
(@jopi)
Miembro eminente Registered

Buenos días Foristas. Una vez más por acá. Quizás más rápido de lo que yo hubiera querido, pero sigo teniendo problemas con los cálculos en VBA. Es algo que no acabo de aprender y necesito aprenderlo.

Acá en mi país cuando un trabajador se enferma y el Médico le da Reposo, emite un Certificado Médico, donde entre otros datos consigna los días a Descansar y la fecha Inicial cuando comienza ese Reposo. Imagino que en todos lados sea parecido, quizás difiera en el cálculo.

Yo quise automatizarle esto a mi esposa para que hiciera los cálculos de manera automática con sólo introducir los datos imprescindibles.

Primero: Declara el Salario devengado por cada uno de los últimos 12 meses y esto crea un Total de Salario. Esto lo logré hacer y funciona perfecto, porque lo que necesito es que se vaya mostrando en los TextBox o Label los resultados en Tiempo Real, pero hay otros cálculos que no he podido lograr, por ejemplo:

Promedio Mes que utilizo la función =SI.ERROR(PROMEDIO(D8:D19),"0.00")

Promedio Día que utilizo la función =SI.ERROR(D21/24,"0.00")

Días a Contar que utilizo =DIAS.LAB.INTL(H8,I8,11,I13) (en el cuarto argumento requiere del rango I13:I20)

Total Días a Pagar =F11-D23

Días x Promedio Días =SI.ERROR(F14*D22,"0.00")

Neto a Cobrar =SI.ERROR(F17*K9/100,"0.00")

El importe de los Meses se introduce manual, al igual que Fecha Inicio (Desde) y Fecha Final (Hasta), al igual que en No Considerar que son fechas de días Feriados, Festivos o simplemente No laborables (no incluye los domingos)

En el Combobox % a Aplicar defino el porciento que requiere el certificado según el Tipo.

En Días de Carencia se introduce manual. Esto son los 3 primeros días de cada certificado que no se les paga, a no ser que el certificado sea continuación de otro.

En la Hoja me funciona PERFECTAMENTE y obtengo lo que necesito, pero quiero hacerlo a través de VBA, pero no logro concretar los cálculos en los TextBox o Label. Esto es una asignatura que sigo teniendo pendiente pero que superaré.

Resumiendo, necesito me ayuden a que los TextBox TxtPromedioDia y TxtPromedioMes me vaya mostrando en Tiempo Real el resultado de las operaciones, así como en los 4 Label.

Aun no lo he terminado, pero con esto me estarían ayudando muchísimo.

Les agradecería su apoyo.

Gracias y que tengan un excelente día.

JIPM

Citar
Topic starter Respondido : 02/12/2021 7:19 pm
Etiquetas del debate
RET
 RET
(@ret)
Miembro Admin

@jopi,

 

No se muy bien que es lo que quieres hacer. Tienes el formulario y tienes la hoja Subsidio. No se si quieres ir metiendo datos en el form y que se vayan volcando a la hoja Subsidio, si quieres meter en la hoja subsidio y que se vuelquen al form o si lo quieres hacer sÓlo en el form y la hoja subsidio la tienes solo como comprobación mientras desarrollas el form.

 

Suponiendo que quieras usar sólo el form (si no, podrías coger los daros calculados en la hoja Subsidio y copiarlos a los campos del form y ya está), tienes varias alternativas:

Reproducir por código lo que hacen las funciones. Por ejemplo, SI.ERROR(PROMEDIO(D8:D19),"0.00"),

la suma ya la tienes (la vas poniendo en el campo Total). Cuenta el número de campos de mes que tienen dato numérico y divide el total por dicho valor. El evento es el mismo que usas ahora para calcular el campo Total.

De todas formas, esto es fácil para algunos cálculos (Promedio), pero en otros, se puede complicar bastante (DIAS.LAB.INTL).

La opción que yo haría sería hacer la hoja Subsidio oculta, ir poniendo los datos de los valores mensuales en su rango correspondiente de dicha hoja, y copiar los valores calculados con las formulas de dicha hoja a los campos del formulario, sin tener que hacer ningún calculo en VBA.

IMF_RET

https://InformaticaMuyFacil.com

ResponderCitar
Respondido : 03/12/2021 1:09 pm
jopi
 jopi
(@jopi)
Miembro eminente Registered

Buenos días RET. Cómo se encuentra de Salud. Espero que bien al igual que su familia.

Buenos días al resto de los miembros del Foro.

Los Campos calculados en la Hoja es para que tuvieran una idea  de los valores que deben ir en cada celda, porque lo que quiero es desde el Formulario introducir los datos y que se volqueen en la Hoja, el problema que tengo es que se me hace muy difícil esto de las operaciones matemáticas en VBA y los Eventos a usar y además que se vayan mostrando en Tiempo Real en los TextBox y Label.

Ya hice la suma de los meses, pero se me está haciendo  un problema lo que va quedando. Realmente tengo que aprender más sobre cálculos y eventos en VBA.

Le adjunto un documento para que tenga una mejor idea de lo que necesito.

Un saludo y cuídese mucho amigo.

Lo respeta y estima.

JIPM

 

ResponderCitar
Topic starter Respondido : 03/12/2021 2:40 pm

Dejar una respuesta

Nombre del autor

Correo electrónico del autor

Título *

 
Vista previa 0 revisiones Guardado